IOS 10 (?) and IPv6-only WLAN

Bernhard Schmidt berni at
Thu Oct 13 10:45:16 CEST 2016


for a couple of years now we have been running an IPv6-only eduroam on
Campus for testing purposes. We use the following setup

- VLAN terminated on Cisco N7k
- wireless clients can't talk to each other
- no IPv4 at all on the network (blocked by Wireless ACLs)
- /64 SLAAC, on-link flag in RA not set
- O-bit set in RA (stateless DHCPv6)
- DHCPv6 relay to ISC DHCP, handing out a dedicated DNS64 resolver
- DNS64 resolver on BIND 9.9, with our own network specific NAT64 prefix
(not 64:ff9b::/96)
- NAT64 gateway with Tayga on Linux

The setup works quite well Linux, Windows (as well as NAT64/DNS64
without 464XLAT works). It doesn't work on Android due to lack of DHCPv6
of course. I think I had tested it with IOS 9.something and it worked
there as well.

Today we've received a report that IOS 10 devices cannot use it. I tried
myself with an iPad running IOS 10.0.2 and I'm unable to use it either.

- device does not show any errors about internet connectivity
- device configures two IPv6 addresses and router from RA
- device receives DNS64 nameserver from stateless DHCPv6
- device eventually configures an autoconf IPv4 address (169.254.x.x)
without a gateway
- I see A/AAAA DNS queries to the DNS64 server
- neither IPv4 nor IPv6 nor dualstacked websites work, the browser just
times out. I cannot see any network activity of the device (but it's
hard to tell, since I'm currently at home)

I don't have an older iOS device to crosscheck.

Does anyone have any ideas what could be wrong?


More information about the ipv6-ops mailing list