Yesterday's Windows update causes IPv4 to be default

Tassos Chatzithomaoglou achatz at
Wed Nov 14 20:16:20 CET 2012

If this is MS's new way of doing HE, then i'm little bit worried about choosing a protocol
based solely on connectivity to an external entity.


Dan Wing wrote on 14/11/2012 20:58:
>> -----Original Message-----
>> From: at [mailto:ipv6-
>> at] On Behalf Of Tassos
>> Chatzithomaoglou
>> Sent: Wednesday, November 14, 2012 9:00 AM
>> To: ipv6-ops at
>> Subject: Re: Yesterday's Windows update causes IPv4 to be default
>> /Assume that a computer is configured to use an IPv6 connection as the
>> default connection.
>> Additionally, assume that the computer does not have a connection to an
>> IPv6 network. In this situation, it takes a long time for the computer
>> to connect to an IPv6 site. // // //This issue occurs because Windows
>> tries the IPv6 connection first. After the connection fails because of a
>> time-out error, Windows tries the IPv4 connection.// // //After this
>> update is installed, Windows uses the NCSI functionality to examine the
>> Ipv6 connection. If the connection is broken, Windows uses IPv4 instead
>> of IPv6./
> Yep, Windows 8 has been doing that since Windows 8 shipped.  Full
> details are in my Cisco Live slide deck (I'll have to find a pointer)
> and a pretty good summary is 
> -d
>> --
>> Tassos
>> Dick Visser wrote on 14/11/2012 18:46:
>>> Hi
>>> I looks like yesterday's batch of updates causes Windows 7 to prefer
>>> IPv4 over IPv6.
>>> After (automatically) installing the whole lot, one of my users
>>> complained about connection issues with WinSCP to our web server.
>>> This runs SSH on IPv6-only. His WinSCP for some reason tried to
>>> connect over IPv4, without falling back to IPv6.
>>> I tried "ping" and that also used IPv4.
>>> "ping -6" did also work, but I'm pretty sure it used to
>>> default to IPv6.
>>> After clearing the cache in WinSCP things started to work again.
>>> I didn't install the updates (about 20, including the Office ones) on
>>> my own computer, so I had a look at them first.
>>> One of them is called "No network connectivity on Windows 7-based or
>>> Windows Server 2008 R2-based client computers when a DHCPv6 message is
>>> sent that has a duplicated DUID",
>>>, which is the only one that
>>> mentions IPv6.
>>> Before installing anything, I tried to "ping" and that
>>> used IPv6 all-right.
>>> I then installed all the updates except the suspicious
>>> After rebooting, "ping" uses IPv4...
>>> So I guess one of the other updates caused this; I'm now booting up a
>>> VM to investigate which one exactly.
>>> So far the no other major stuff broke, and it looks like only the
>>> default has changed, but I'd thought I mentioned it here anyway, just
>>> in case...
>>> Anyone else has seen IPv6 issues on Windows since yesterday?

More information about the ipv6-ops mailing list