Yesterday's Windows update causes IPv4 to be default

Dick Visser visser at
Wed Nov 14 17:46:26 CET 2012


I looks like yesterday's batch of updates causes Windows 7 to prefer
IPv4 over IPv6.
After (automatically) installing the whole lot, one of my users
complained about connection issues with WinSCP to our web server.
This runs SSH on IPv6-only. His WinSCP for some reason tried to
connect over IPv4, without falling back to IPv6.
I tried "ping" and that also used IPv4.
"ping -6" did also work, but I'm pretty sure it used to
default to IPv6.
After clearing the cache in WinSCP things started to work again.

I didn't install the updates (about 20, including the Office ones) on
my own computer, so I had a look at them first.
One of them is called "No network connectivity on Windows 7-based or
Windows Server 2008 R2-based client computers when a DHCPv6 message is
sent that has a duplicated DUID",, which is the only one that
mentions IPv6.

Before installing anything, I tried to "ping" and that
used IPv6 all-right.
I then installed all the updates except the suspicious
After rebooting, "ping" uses IPv4...

So I guess one of the other updates caused this; I'm now booting up a
VM to investigate which one exactly.
So far the no other major stuff broke, and it looks like only the
default has changed, but I'd thought I mentioned it here anyway, just
in case...

Anyone else has seen IPv6 issues on Windows since yesterday?

Dick Visser
System & Networking Engineer
TERENA Secretariat
Singel 468 D, 1017 AW Amsterdam
The Netherlands

More information about the ipv6-ops mailing list