enabling IPv6 on Cisco 6500 breaks IPv4 Internet connectivity

Jim Trotz jtrotz at gmail.com
Sun Jun 10 01:31:07 CEST 2012

Here is an update:

In the lab we confirmed that a 6500 router with a full IPV4 configuration
(VRFs, MPLS, MBGP [full table]) hangs when  2 ipv6 commands are entered (no
other ipv6 commands - addresses, ect.) The problem happen when these
commands are applied or removed.

The commands are 'ipv6 unicast-routing' and adding 'ipv6 address-family'.
Added separately - no problem. Both together - problem.
Note: 'mls ipv6 vrf' was already there.

Further lab testing shows that IPV4 ICMP & UDP & TCP traffic still pass
through the router during the "hang" period. IPV4 UDP & TCP traffic comes
to a crawl (0-2000bs/sec). I was wrong earlier when I said that only TCP
was affected. I have switched to using "curl" for both TFTP & HTTP gets and
it has a good progress meter that shows the throughput. Before, I was only
estimating throughput using the basic tftp command.

 I have 3 xfers going at the same time both from the outside to inside and
from the inside to the outside. The 3 XFERS are:

1)  ipv4 ICMP pings to a host on the other side of the router.

2)  TFTP  (ipv4 udp port 69) GETs for a large file from a host on the other
side of the router.

3)  HTTP GETS  (ipv4 tcp port 80) for a large file from a host on the other
side of the router.

Both the TFTP & HTTP GETs slow to a crawl (ICMP seems unaffected) when
'ipv6 unicast-routing' is entered.


Tried removing configuration lines one-at-a-time to get to a point that
this doesn't happen. (i.e. no ip multicast-routing) - no luck.

Tried removing ipv6 configuration from the interfaces on the neighbor
routers going to the test router - no luck.


Also, noticed that if I shutdown the uplinks to the Internet Hubs then the
problem goes away, even before BGP neighbors go into ACTIVE status.  (The
data path in my tests does not use these uplinks, just ports on trhe test

Note: in the LAB the router only has local ICMP, PC file copy + EIGRP & BGP
neigbor traffic for a load  and still has most of the symptoms of a hang
(1.5-3 min) - the production router hang will be MUCH longer.

I did a bunch of show "proc cpu sorted" cli commands during a hang and no
one process floated to the top, just the usual background processing.


Got Cisco SE to call the 6500 business unit for help.

So this might be some kind of delay due to processor activity or CEF
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.cluenet.de/pipermail/ipv6-ops/attachments/20120609/49ff757b/attachment.html 

More information about the ipv6-ops mailing list