mtu

Daniel Roesen dr at cluenet.de
Tue Feb 3 00:47:35 CET 2009


On Tue, Feb 03, 2009 at 12:13:55AM +0100, Bernhard Schmidt wrote:
> The most common issues are IPv6 tunnels on interprovider links.

Indeed, this is in line with my observations over the years.

> Most implementations (including Cisco and Juniper) set the IPv6 MTU of the
> tunnel to the IPv4 MTU (to the tunnel destination) minus 20/24 bytes of
> overhead.

Cisco IOS and Juniper JUNOS derrive the tunnel payload MTU from the
physical egress interface MTU the tunnel traverses over at any given
moment in time.

So it's best practise to always nail your tunnel MTU to the proper value
according to what you can guarrantee between the tunnel end points.

For IOS:

interface Tunnel1
 tunnel mode gre ip (default)
 ipv6 mtu 1476
interface Tunnel2
 tunnel mode ipv6ip
 ipv6 mtu 1480

For JUNOS:

interfaces {
    // GRE
    gr-0/0/0 {
        unit 1 {
            family inet6 {
                mtu 1476;
            }       
        }           
    }
    // IPv6-in-IP      
    ip-0/0/0 {
        unit 1 {    
            family inet6 {
                mtu 1480;
            }       
        }           
    }               
}

Beware: this is payload MTU. Above MTU will result in max 1500 octet tunnel
packets. Using GRE features like keying will increase tunnel overhead so
payload MTU has to be lowered.


Best regards,
Daniel

-- 
CLUE-RIPE -- Jabber: dr at cluenet.de -- dr at IRCnet -- PGP: 0xA85C8AA0


More information about the ipv6-ops mailing list