BGP over 2002::/16

Iljitsch van Beijnum iljitsch at muada.com
Mon Dec 17 20:25:52 CET 2007


Hi,

I finally managed to get my test hardware set up. This is a Cisco  
config that lets you peer across 6to4:

!
ipv6 unicast-routing
!
interface Loopback2002
  no ip address
  ipv6 address 2002:52C0:5A1A::1/128
!
interface Tunnel2002
  no ip address
  ipv6 unnumbered Loopback2002
  tunnel source 82.192.90.26
  tunnel mode ipv6ip 6to4
!
router bgp 9000
  neighbor 2002:5395:4101::1 remote-as 12854
  neighbor 2002:5395:4101::1 ebgp-multihop 255
  neighbor 2002:5395:4101::1 update-source Loopback2002
  !
  address-family ipv6
  neighbor 2002:5395:4101::1 activate
  exit-address-family
  !
  address-family ipv4
  no neighbor 2002:5395:4101::1 activate
  exit-address-family
!
ipv6 route 2002::/16 Tunnel2002
!

To show you that it really works:

RouterI#traceroute www.freebsd.org
Translating "www.freebsd.org"...domain server (2001:1AF8:2:5::2) [OK]

Type escape sequence to abort.
Tracing the route to www.freebsd.org (2001:4F8:FFF6::21)

   1 2002:5395:4101::1 44 msec 32 msec 32 msec
   2 2001:1AF8:2:5::1 228 msec 112 msec 124 msec
   3 2001:1AF8:1:15:20E:39FF:FE3C:2AAA 120 msec 120 msec 116 msec
   4 2001:5A0:200:100::9 116 msec 108 msec 116 msec
   5 2001:5A0:200::5 268 msec 188 msec 224 msec
   6 2001:7F8:1::A500:2914:2 136 msec 132 msec 132 msec
   7 2001:728:0:2000::1E 132 msec 144 msec 144 msec
   8 2001:728:0:2000::121 136 msec 128 msec 144 msec
   9 2001:418:0:2000::1DE 200 msec 200 msec 204 msec
  10 2001:418:0:2000::1A1 196 msec 192 msec 204 msec
  11 2001:418:0:2000::29E 204 msec 216 msec 188 msec
  12 2001:418:1C00:5000::A 216 msec 360 msec 380 msec
  13 2001:4F8:0:1::50:2 216 msec 212 msec 216 msec
  14 2001:4F8:0:1::3E:2 216 msec 184 msec 200 msec
  15 www.freebsd.org (2001:4F8:FFF6::21) 216 msec 224 msec 216 msec

RouterI#show ipv6 route
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
        U - Per-user Static route
        I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
        O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF  
ext 2
B   ::/0 [20/0]
      via 2002:5395:4101::1, Null
S   2001:DB8::/32 [1/0]
      via ::, Null0
S   2002::/16 [1/0]
      via ::, Tunnel2002
LC  2002:52C0:5A1A::1/128 [0/0]
      via ::, Loopback2002
B   3FFE:2500:310::/48 [20/0]
      via 2002:5395:4101::1, Null
L   FE80::/10 [0/0]
      via ::, Null0
L   FF00::/8 [0/0]
      via ::, Null0

If anyone wants to see if the proper next hop processing for an MLPA  
configuration happens in this case, let me know and we'll set up some  
multi-party peering.


More information about the ipv6-ops mailing list